Cisco srw 2024 only works with IE7 or worse

The Cisco / Linksys srw 2024 is not really a bad switch. What is really sad that the web interface will only work in IE7 or before. It will fail in any modern browser. There is nothing fancy about a web interface for a network switch. No need to use anything IE specific at all. No need to seemingly do it in a way that IE8 simply stops working. I think Cisco should either stop selling the device, update it, or at the very least put a note in the box that it requires IE7 or below to operate. If they would care that is.

Leave a Reply

You must be logged in to post a comment.